Need help staking my AGI tokens for the next staking pool

Hello! I recently transferred some ETH to MyETHwallet on my cell (Android), swapped it for AGI, then transferred my AGI to my ETH account on MetaMask on 9-4-20 so that I could stake it prior to the the AGI staking. I made several attempts over the 7 day period to stake my entire AGI tokens (more than 500) prior to the staking pool that closed today 9-11-20. However, the transactions never happened, they appeared to be in a loop and was unable to finalize the transactions. The messages that appeared on SingularityNet pool screen were “Transaction Pending” AND I was never able to approve the transactions on my MetaMask extension. Please advise on how I can submit my AGI tokens for the next AGI pool. Don’t know if it’s my Mac (the software is up to date), my VPN…I have high speed connection so I’m sure it’s not that. A step-by-step procedure on what I need to do to successfully complete the transaction would be great! Thanks.

Hey there, LMD1966.

Yeah, I had this problem too. You have to use Metamask and look at the ETHgas fee and see if everything is working out correctly. Fix up that Metamask wallet and see if everything is going right and that you’ve paid the ETH gas fee to send your AGI tokens to SingularityNET’s staking platform (which isn’t cheap by the way) and try this out one more time. Also, take a good look at the “Queue” button in your Metamask to see if there are any pending transactions, of which you’ll unfortunately have to pay even to cancel. (I know, Metamask sucks), but hopefully this will fix your problem and you’ll be able to send those AGI tokens right up. You won’t lose your tokens but if there is a huge queue on your Metamask wallet (by having tried way too many times), you’ll have to pay a very small ETH fee for every transaction you’ve tried, but you won’t lose your AGI. This happened to me quite a few times and I had to pay the fee cancellations but was able to stake just the right amount of AGI. Perhaps you have no ETH in your wallet and that’s why it’s refusing itself to finish the transactions getting stuck at “Pending” indefinitely – that is, until you get ETH to finish (speed up) your transactions. Hope that helps. Keep me informed.

-Karamazov

1 Like

Thank you very much, Karamazov! I will try that when the next staking pool comes aound!